umax at mac os x

UMAX Scanners and Mac OS X

UMAX MagicScan 4.5 software does not work at Mac OSX at all and the MagicScan 5.1 only works for OS10.1~10.2.8. So, what is the solution for the OS version after OS10.2.8? The third party software SilverFast (SE, Ai, HDR, HDR Studio) is the answer! SilverFast software can completely replace the MagicScan software for Mac OSX user. 

Please see the links below for a wide variety of tech support docs in regards to OS X


SilverFast SE supported models listed for OS X. These are the Models that Umax has tested and supports in OS X with LaserSoft's SilverFast SE software. If it isn't on the list, it may work, but has proven difficult for us and is therefore not supported. You can also buy the software from us at this link below. SilverFast SE supported Models list For OS X 

SilverFast Ai and Supported Models listed for OS X. These are the Models that Umax has tested and supports in OS X with LaserSoft's SilverFast Ai software. If it isn't on the list, it may work, but has proven difficult for us and is therefore not supported. You can also buy the softer from us at this link below. SilverFast Ai and Supported Models list for OS X 

SCSI support getting to troublesome, expensive and/or way too time consuming for you? Want your 2100XL to work on a Mac OS X system without a SCSI card? If so, please see our 2100XL Mac Pro, G5 Quad, PowerBook, and all iMac models solution at the link below. 2100XL G5 Quad, MacBook Pro, PowerBook, and al iMac models solution 

SCSI support getting to troublesome, expensive and/or time consuming for you? Want other Umax SCSI scanners besides the Powerlook 2100XL to work on a Mac OS X system without a SCSI card? If so, please see our Umax SCSI G5 Quad, MacBook Pro, PowerBook, and all iMac models solution at the link below. Make your SCSI scanner work with USB in OS X

SCSI cards supported by Umax in OS X. This is more of document to show you how to get your SCSI scanner working in OS X. Why buy a new model when you can keep your current one working? SCSI cards supported by Umax in OS X 

Uninstall MagicScan from OS X to get rid of "System extension cannot be used? error message that causes SilverFast Ai or SE to give the ?Scanner not found!" error. MagicScan is not supported past OS X revision 10.2.8. SilverFast and MagicScan cannot be installed on the same system or it will not work. See the link below to fix that problem. Beware, it directs you to drop MagicScan and use SilverFast only. Uninstall MagicScan from OS X 

Fix for when SilverFast won't launch in 10.3.9 for Astra 6700. Once you have installed the QuickTime updates for system 10.3.9, you may not be able to launch the SilverFast Software to get your Astra 6700 working. Take advantage of the document at t he link below to correct this problem. Beware; The Astra 6700 is not supported in OS X version 10.4 or beyond. Fix for when SilverFast won't launch in 10.3.9 for Astra 6700